Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Install 1.2.0 on mac issues

I have problems with 1.2.0 installation:

sudo ./install 
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
./install: line 69: glibtoolize: command not found

But libtool installed ```sh libtool --version libtool (GNU libtool) 2.4.2 Written by Gordon Matzigkeit <[email protected]>, 1996

Copyright (C) 2011 Free Software Foundation, Inc. ```

And autoconf is latest: ```sh autoconf --version autoconf (GNU Autoconf) 2.69 Copyright (C) 2012 Free Software Foundation, Inc. License GPLv3+/Autoconf: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>, <http://gnu.org/licenses/exceptions.html> This is free software: you are free to change and redistribute it. There is NO WARRANTY, to the extent permitted by law.

Written by David J. MacKenzie and Akim Demaille. ```

Mac OS 10.8.4



1.7k

To resolve this issue, open build/install and comment this lines:

#GNU 'libtoolize' on MAC OS X is called 'glibtoolize'
#if [ `(uname -s) 2>/dev/null` == 'Darwin' ]
#then
#  LIBTOOLIZE_BIN="glibtoolize"
#fi

Now it installs and works but still have ```sh aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in' ``` notice when running installation script :(



82.3k

That notice does not represent a problem for phalcon itself, is just a warning about the old format used in the configuration files ;)



1.7k

FYI I use libtool installed from sources in my mac. Not from ports.

So thats why maybe I don't have glibtoolize.



1.7k
Accepted
answer

Fixed. At least in 1.2.3. Thanks!