max lifetime session memcached

        $memcache = new Phalcon\Session\Adapter\Memcache(array(
            'host'       => '127.0.0.1',          // mandatory
            'port'       => 11211,                // optional (standard: 11211)
            'lifetime'   => (60 * 60 * 24 * 30),  // optional (standard: 8600)
            'persistent' => false                 // optional (standard: false)
        ));

Good day! What is the maximum lifetime that can be set in parameter 'lifetime'?

If you set more than 30 days, then the plug-in does not work ... Need to be at least about 120 days

thx!



1.5k
edited Oct '15

hi, I have the same problem too,

but I figure out, it's not phalcon problem, it's php memcache lib limit

reference: http://php.net/manual/en/memcache.set.php

if you give interger as parameter of lifetime, it may not exceed 2592000.

but you can give UNIX timestamp to make it over 30 days.

for example:

'lifetime' => strtotime('+120 day'),

also you can set it to zero for never expire.
)

also you can set it to zero for never expire. :)

Are you sure?