Some warning when installing Phalcon 2.0.0

Sorry, I'm new with phalcon. i've tried to install phalcon on homestead. I follow tutorial from this site and i get some warning like this..

Warning: Class "APCIterator" does not exist at compile time in /home/vagrant/code/cphalcon/phalcon/cache/backend/apc.zep on 224 [nonexistent-class]

   apc = new \APCIterator("user", prefixPattern);
------------------------------------------------^

Warning: Class "APCIterator" does not exist at compile time in /home/vagrant/code/cphalcon/phalcon/cache/backend/apc.zep on 268 [nonexistent-class]

  for item in iterator(new \APCIterator("user")) {
-----------------------------------------------^

Warning: Function "phalconormsinglequotes" does not exist at compile time in /home/vagrant/code/cphalcon/phalcon/mvc/model/query.zep on 516 [nonexistent-function]

       let escapedValue = phalcon_orm_singlequotes(value);
---------------------------------------------------------^

Copying new kernel files... Preparing for PHP compilation... Preparing configuration file... Compiling... Installing... Extension installed! Add extension=phalcon.so to your php.ini Don't forget to restart your web server /usr/local/bin/zephir: line 39: 6693 Segmentation fault (core dumped) php $ZEPHIRDIR/compiler.php $*

is phalcon 2.0.0 ready for production ?



85.0k

You're getting some warnings instead of errors of which are innofensive



2.1k

This seems to be benign as everything still works as normal. It just breaks any type of build script you have that expects the build to exit properly