Incubator with 2.0.0r

Per the Github issue, this is fixed: https://github.com/phalcon/incubator/issues/293

but when I try to do composer require phalcon/incubator:dev-master, it still displays the same error. Am I missing something?

[email protected]:/var/www/html/app$ php composer.phar require phalcon/incubator:dev-master
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for phalcon/incubator dev-master -> satisfiable by phalcon/incubator[dev-master].
    - phalcon/incubator dev-master requires ext-phalcon >=1.2.4 -> the requested PHP extension phalcon has the wrong version (2.0.0r) installed.


Installation failed, reverting ./composer.json to its original content.

Thanks, Chris

Hello,

I had this problem too and is not from incubator or phalcon. Seems like apache doesn't see the module. Try this:

// Create extension ini file in /etc/php5/mods-available
echo 'extension=/path/to/phalcon.so' | sudo tee -a /etc/php5/mods-available/phalcon.ini

// Activate mod
sudo php5enmod phalcon

// Restart apache
sudo service apache2 restart


2.1k
edited Apr '15

Hi Stefan, I was really hoping you were right but unfortunately, phalcon is enabled. I have done this before about 3-4 months ago (using Vagrant but maybe a different release of phalcon 2.x and phalcon-incubator) and it went ok.

I am using nginx + php5-fpm and using the standard build for 2.x per the instructions (from installing zephir all the way up to zephir build for phalcon) and it puts the 30-phalcon.ini in the right places

/etc/php5/fpm/conf.d/30-phalcon.ini -> ../../mods-available/phalcon.ini 
/etc/php5/cli/conf.d/30-phalcon.ini -> ../../mods-available/phalcon.ini => this is what the CLI uses

and double checking it by

cd /var/www/html/app (just to be sure)
php -i | grep phalcon
/etc/php5/cli/conf.d/30-phalcon.ini
phalcon  
phalcon => enabled

which is basically the same way I do

cd /var/www/html/app (same place as above)
php composer.phar require phalcon/incubator:dev-master

If I remove the 30-phalcon.ini -> ../../mods-available/phalcon.ini, I get a different response on the grep

php -i | grep phalcon
/etc/php5/cli/conf.d/30-phalcon.ini

and a different response on composer (telling me it cannot find Phalcon)

 php composer.phar require phalcon/incubator:dev-master
 ./composer.json has been updated
 Loading composer repositories with package information
 Updating dependencies (including require-dev)
 Your requirements could not be resolved to an installable set of packages.

  Problem 1
  - Installation request for phalcon/incubator dev-master -> satisfiable by phalcon/incubator[dev-master].
  - phalcon/incubator dev-master requires ext-phalcon >=1.2.4 -> the requested PHP extension phalcon is missing from your system.

 Installation failed, reverting ./composer.json to its original content.
edited Apr '15

I had this problem too on my nginx server with phalcon 2 and I just took a few minutes to solve it. I added

extension=/path/to/phalcon.so

in these files

/etc/php5/fpm/conf.d/20-phalcon.ini
/etc/php5/fpm/php.ini

then

sudo ln -s /etc/php5/fpm/conf.d/20-phalcon.ini /etc/php5/mods-available/phalcon.ini
sudo service nginx restart
sudo service php5-fpm restart

That's all I did and now I can install incubator via composer