Error compilation Phalcon 2.0

I'm trying migrate to phalcon 2.0, but when I execute ./install in build I got this error:

/bin/bash /home/cphalcon/build/64bits/libtool --mode=compile gcc -I. -I/home/cphalcon/build/64bits -DPHPATOMINC -I/home/cphalcon/build/64bits/include -I/home/cphalcon/build/64bits/main -I/home/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCONRELEASE -DHAVECONFIGH -march=native -mtune=native -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden -c /home/cphalcon/build/64bits/phalcon.zep.c -o phalcon.lo libtool: compile: gcc -I. -I/home/cphalcon/build/64bits -DPHPATOMINC -I/home/cphalcon/build/64bits/include -I/home/cphalcon/build/64bits/main -I/home/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCONRELEASE -DHAVECONFIGH -march=native -mtune=native -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden -c /home/cphalcon/build/64bits/phalcon.zep.c -fPIC -DPIC -o .libs/phalcon.o /home/cphalcon/build/64bits/phalcon.zep.c: Assembler messages: /home/cphalcon/build/64bits/phalcon.zep.c:13444: Error: incorrect register %edi' used withq' suffix /home/cphalcon/build/64bits/phalcon.zep.c:13448: Error: incorrect register %edi' used withq' suffix make: * [phalcon.lo] Error 1

Anyone know how resolve this?

edited Apr '15

Compile from ext:

cd cphalcon/ext
sudo ./install


2.3k

same error:

libtool: compile: gcc -I. -I/home/cphalcon/ext -DPHPATOMINC -I/home/cphalcon/ext/include -I/home/cphalcon/ext/main -I/home/cphalcon/ext -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVECONFIGH -O2 -Wall -fvisibility=hidden -flto -DZEPHIRRELEASE=1 -c /home/cphalcon/ext/kernel/require.c -fPIC -DPIC -o kernel/.libs/require.o libtool: compile: gcc -I. -I/home/cphalcon/ext -DPHPATOMINC -I/home/cphalcon/ext/include -I/home/cphalcon/ext/main -I/home/cphalcon/ext -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVECONFIGH -O2 -Wall -fvisibility=hidden -flto -DZEPHIRRELEASE=1 -c /home/cphalcon/ext/kernel/file.c -fPIC -DPIC -o kernel/.libs/file.o libtool: compile: gcc -I. -I/home/cphalcon/ext -DPHPATOMINC -I/home/cphalcon/ext/include -I/home/cphalcon/ext/main -I/home/cphalcon/ext -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVECONFIGH -O2 -Wall -fvisibility=hidden -flto -DZEPHIR_RELEASE=1 -c /home/cphalcon/ext/kernel/operators.c -fPIC -DPIC -o kernel/.libs/operators.o /home/cphalcon/ext/kernel/operators.c: Assembler messages: /home/cphalcon/ext/kernel/operators.c:1101: Error: incorrect register %edx' used withq' suffix /home/cphalcon/ext/kernel/operators.c:1105: Error: incorrect register %esi' used withq' suffix make: * [kernel/operators.lo] Error 1

Which processor do you have? It seems GCC is choosing wrong instructions for your processor



2.3k

SO: Linux 13.04

  • *-cpu
  • description: CPU
  • product: Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz
  • vendor: Intel Corp.
  • physical id: 41
  • bus info: [email protected]
  • version: Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz
  • slot: SOCKET 0
  • size: 1200MHz
  • capacity: 3800MHz
  • width: 64 bits
  • clock: 100MHz
  • capabilities: x86-64 fpu fpuexception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp constanttsc archperfmon pebs bts repgood nopl xtopology nonstoptsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor dscpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse41 sse42 x2apic popcnt tscdeadlinetimer aes xsave avx f16c rdrand lahflm ida arat epb xsaveopt pln pts dtherm tprshadow vnmi flexpriority ept vpid fsgsbase smep erms cpufreq
  • configuration: cores=4 enabledcores=4 threads=8
edited Oct '15

I have the same issue on gcc version 4.7.2 (Debian 4.7.2-5) , have you solved this?