Which LAMP php.ini file do you add extension=phalcon.so to?

I currently have the phalcon extension extension=phalcon.so residing in /etc/php5/apache2/php.ini, but whe I try to install the dev tools it says that

[email protected]:~/phalcon-devtools$ . ./phalcon.sh ERROR: Phalcon extension isn't installed, follow these instructions to install it: http://docs.phalconphp.com/en/latest/reference/install.html

it's clearly installed in /etc/php5/apache2/php.ini and I've restarted the server several times.......



82.2k

Try checking where is your php.ini on CLI:

php -i | grep Loaded

ok, so I was wrong it was loading this

[email protected]:~$ php -i | grep Loaded Loaded Configuration File => /etc/php5/cli/php.ini libXML Loaded Version => 20900

so many php.ini files

OK, only now it's screaming at me

[email protected]:~/phalcon-devtools$ . ./phalcon.sh Phalcon DevTools (1.2.1) Error: Incorrect usage



82.2k

It means installation is OK, it's expecting a command for phalcon devtools:

try: phalcon commands or phalcon model

[email protected]:~/phalcon-devtools$ phalcon commands phalcon: command not found

If 'phalcon' is in '~/phalcon-devtools' then you will have to run

./phalcon commands

as *NIXes by default do not search the current directory for the executable files.