Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

readAttribute undefined in 2.0

After the Phalcon upgrade to 2.0 i see this

[] [?] Fatal error: Call to undefined method Phalcon\Mvc\Model\Row::readAttribute() in xxxxxxxx....volt.php on line 29

a relevant exception from cashed php file from the line 29: <?php echo $item->readAttribute($attribute_name_from_variable); ?>

Is it because it is undefined 2.0 so far or something else? That readAttribute was very useful in 1.3 :(

update: Not sure whether it matters or not but it is sqlite connection , but it shouldn't matter, should it?



5.6k
Accepted
answer
edited May '15

Ok, the function exists i am sure because it's another kind of problem, because i don't see other values for my model objects like {{item.id}}, and must find out why. When i know something i'll write about it and this topic should rather be closed but...

Update: thats right. My problems with attributes had something to do with this thing: http://forum.phalconphp.com/discussion/6742/left-join-count-results-differ-between-13-and-20