phalcon2.0 change to phalcon 1.3.4

First, i had installed the phalcon2.0 extend, and it work. Then i found that we just need the phalcon1.3.4 in our team. My question is how to uninstall my phalcon2.0? Do i need to do so? Or there are some others methods?

The reason why i want to change to phalcon 1.3.4 is : when i use the Page Class it alway warging: Fatal error: Class Base\Paginator\Simple contains 2 abstract methods and must therefore be declared abstract or implement the remaining methods (Phalcon\Paginator\AdapterInterface::setLimit, Phalcon\Paginator\AdapterInterface::getLimit) in /web/xxxx/app/library/Base/Paginator/Simple.php on line 85



7.1k
git clone git://github.com/phalcon/cphalcon.git
cd cphalcon
git checkout 1.3.4
cd build
./install

You should implement both getLimit/setLimit in your class Base\Paginator\Simple:

namespace Base\Paginator;

use Phalcon\Paginator\AdapterInterface;

class Simple implements AdapterInterface
{
    // ...

    public function getLimit()
    {
    }

    public function setLimit($limit)
    {
    }
}


1.1k

thank you so much~, well done !



1.6k

git checkout 1.3.4 not working

```bash git clone git://github.com/phalcon/cphalcon.git cd cphalcon git checkout 1.3.4 cd build ./install ```



1.6k

I too wants to move to 1.3.4, custom validation not working in 2.0.7.