Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon installation on CentOS

I have installed phalcon on CentOS 6. Its showing following messages after installation however phalcon is not installed properly.


Build complete. Don't forget to run 'make test'.

Installing shared extensions: /usr/lib64/php/modules/

Thanks for compiling Phalcon! Build succeed: Please restart your web server to complete the installation

I have restarted web server but still not able to see phalcon in phpinfo or in modules (print_r(get_loaded_extensions());)

Its giving error in error_log PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/phalcon.so' - /usr/lib64/php/modules/phalcon.so: undefined symbol: php_json_encode in Unknown on line 0



1.2k
Accepted
answer

This is due to the way PHP is packaged in CentOS: http://forum.phalconphp.com/discussion/664/after-upgrading-from-php5-5-to-php5-5-1-an-error-occurs

In brief, just create a file /etc/php.d/zzzzz.ini with

extension=phalcon.so

and restart the web server; this should do the trick.

worked, thanks.

Duut, you saved me! It finally works! Woohoo! I got it working with Plesk also now :-)

worked, thanks!



12.0k

I'm using Fedora 21, and faced with same problem, the solution for me was, change the priority of the phalcon ini file to 50, e.g 50-phalcon.ini and JSON ini to the 40-json.ini (it's actually default priority for json ini)