Installation failed: make: *** [phalcon.lo] Erreur 1

Hello,

I can't complete the installation on my virtual server at DigitalOcean...

configure: creating ./config.status config.status: creating config.h config.status: executing libtool commands /bin/sh /root/cphalcon/build/64bits/libtool --mode=compile gcc -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -O2 -fno-delete-null-pointer-checks -finline-functions -fomit-frame-pointer -fno-builtin-memcmp -fvisibility=hidden -c /root/cphalcon/build/64bits/phalcon.c -o phalcon.lo libtool: compile: gcc -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -O2 -fno-delete-null-pointer-checks -finline-functions -fomit-frame-pointer -fno-builtin-memcmp -fvisibility=hidden -c /root/cphalcon/build/64bits/phalcon.c -fPIC -DPIC -o .libs/phalcon.o gcc: Erreur internal error: Processus arrêté (programme cc1) SVP soumettre un rapport complet d'anomalies. Consulter http://bugzilla.redhat.com/bugzilla pour les instructions. make: *** [phalcon.lo] Erreur 1

This looks like a bufg in gcc and not in phalcon: gcc: Erreur internal error: Processus arrêté (programme cc1)

cc1 is a part of gcc suite.

I think you will need to file a bug report to gcc developers or at http://bugzilla.redhat.com/bugzilla

Thanks for your answers!

I found out that my VM didn't have a swap file... So, I simply added one and completed compilation without problem.

But now, the extension can't be loaded... I added "extension:phalcon.so" in my php.ini, "/usr/lib64/php/modules/phalcon.so" exists and restarted my web server...

If you run 'php -v', what error does it display?

It seems to me that you are running Phalcon on CentOS; if so, please make sure to read this: http://forum.phalconphp.com/discussion/664/after-upgrading-from-php5-5-to-php5-5-1-an-error-occurs

I created the file /etc/php.d/phalcon.ini to load the extension and Phalcon is now loaded :-)

Thanks for your help!