Unable to install legacy phalcon on debian

I need to compile and install phalcon v1 on my server, because my app uses legacy version. 1.2.4 version, that was used in my app, is not able to compile. I tried to pick latest 1.* version (it's 1.3.4), it was compiled successfully. After installation i see following errors:

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/phalcon.so' - /usr/lib/php5/20131226/phalcon.so: undefined symbol: php_json_decode_ex in Unknown on line 0 PHP 5.6.9-0+deb8u1 (cli) (built: Jun 5 2015 11:03:27) Copyright (c) 1997-2015 The PHP Group Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies with Zend OPcache v7.0.4-dev, Copyright (c) 1999-2015, by Zend Technologies

Make sure that the JSON extension is loaded before the phalcon extension



507

This is still relevant for phalcon 2.1.x / PHP7 / debian8.