Non existing url on russian language are redirected to main page without 404 err

If you write some blabla url at phalcon site using russian letters like this: YourSite.com\проверка no 404 error happens, only redirect to main page. Tested on Invo and Vokuro applications. Is it Routing bug?

This is not a routing bug. It is the default routing behavior. When it can't find a valid controller/action, by default goes for index. You can modify this default behavior or disable it and set your own behavior: $router = new Phalcon\Mvc\Router(false);

Also you can set a behavior for when no routes are matched. Beware that this works only if no route is matched and not when it doesn't find a controller/index. To handle not found controllers/actions you need to set an event in dispatcher.

https://docs.phalconphp.com/en/latest/reference/dispatching.html#handling-not-found-exceptions https://docs.phalconphp.com/en/latest/reference/routing.html#not-found-paths https://docs.phalconphp.com/en/latest/reference/routing.html#setting-default-paths