Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Glib error

I am trying to run Phalcon on my shared host for the second time. I have tried it with 1.3.0 I lelieve some time ago and it worked fine. Now I'm trying 2.0.3.

There's no way that I can compile phalcon on the server so I have to compile it on a similar environment. I heard cPanel is usually ran under red hat or cent os, so I installed CentOS 7 and the latest php available on linux which is still on 5.4.16 for some reason. The server runs PHP 5.4.30 which I can't get for linux (help?).

[29-Jun-2015 01:27:36 UTC] PHP Warning: PHP Startup: Unable to load dynamic library '/home/cloudlog/public_html/phalcon/phalcon.so' - /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/cloudlog/public_html/phalcon/phalcon.so) in Unknown on line 0

So this error is returned when I try to load the phalcon.so extension.

I'm not sure if that's because I compiled it with a different php version or the wrong distribution.

Any ideas?



12.8k
Accepted
answer

most likely is a wrong distribution. Most cPanel shared hosts work on centos 6.6

https://en.wikipedia.org/wiki/CentOS - scroll down to "CentOS releases" and compare the kernel version with yours.

To get php 5.4 in centos 6.6 you need to add some external repositories. Just do a google search for "php 5.4 centos 6.6" and you'll find lots of solutions

That did it. Thank you!