Install Linux with XAMPP

Hi,

Ubuntu flavor 12.04, XAMPP with PHP Version 5.6.8.

I tried to install but do not see Phalcon in PHPInfo, I have extension=phalcon.so in /opt/lampp/etc/php.ini

I tried this but it did not work

:~/cphalcon/build$ sudo ./install --with-php-config=/opt/lampp/bin/php-config ./install: line 55: cd: --: invalid option cd: usage: cd [-L|[-P [-e]]] [dir] Cannot find config.m4. Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

So i tried ~/cphalcon/build$ ./install

It says the libs are in my home dir below. Is this OK?

It seemed to work:

Libraries have been installed in: /home/user1/cphalcon/build/32bits/modules

..snip...

Build complete. Don't forget to run 'make test'.

Installing shared extensions: /usr/lib/php5/20090626+lfs/ Installing header files: /usr/include/php5/

Thanks for compiling Phalcon! Build succeed: Please restart your web server to complete the installation

But I do not see Phalcon in phpinfo(), did it work? There was some documentation that said to do make test but that gives:

~/cphalcon/build$ make test

Thanks make: * No rule to make target `test'. Stop.

So I'm use to binary packages just working...need help to figure out what's going on. Thanks

Use ./install probaby does not work because it takes the php-config and phpize available in $PATH, you might need to follow these instructions:

git clone https://github.com/phalcon/cphalcon
cd cphalcon/ext
alias phpize=/opt/lampp/bin/phpize
export CC="gcc"
export CFLAGS="-O2 -Wall -fvisibility=hidden -flto -DZEPHIR_RELEASE=1"
phpize --with-php-config=/opt/lampp/bin/php-config
./configure --enable-phalcon
make --silent && sudo make --silent install


805

Use ./install probaby does not work because it takes the php-config and phpize available in $PATH, you might need to follow these instructions:

``` git clone https://github.com/phalcon/cphalcon cd cphalcon/ext alias phpize=/opt/lampp/bin/phpize export CC="gcc" export CFLAGS="-O2 -Wall -fvisibility=hidden -flto -DZEPHIR_RELEASE=1" phpize --with-php-config=/opt/lampp/bin/php-config ./configure --enable-phalcon make --silent && sudo make --silent install ```

I did exactly what you said. No errors I could see. tried extension=phalcon.so and extension="phalcon.so" in /opt/lampp/etc/php.ini, restarted, $ sudo /opt/lampp/lampp restart.

Still no mention of Phalcon in phpinfo(). Is there anything else to try? Something I'm not doing but should do? Any info I can supply?

Thanks

Here's what i had done in my server:

sudo nano /etc/php5/mods-available/phalcon.ini

Write this line

extension=phalcon.so

Create symlink:

sudo ln -s /etc/php5/mods-available/phalcon.ini /etc/php5/fpm/conf.d/30-phalcon.ini

Then restart your php services