Unable to restart apache2 after Phalcon compilation

Hi,

as I was trying to setup a new small Ubuntu 14.04 Server for an older Phalcon project, I was unable to restart apache2 after successfully compiling the phalcon legacy version.

It seems that i ran out of memory (2GB of RAM on a VPS). Now on my old Server I never experienced anything like this. Is there a way to use phalcon on such a small server?

Soda

PS: I only found posts about compilation errors due to lack of rescources.

edited Jul '15

I'm not sure that might be a phalcon problem. I use phalcon on a 1GB ram VPS without problems and first, phalcon doesn't need so much ram at all. Can you tell us exactly what phalcon version you're trying to compile? Maybe try to recompile, or use another version.

I did recompile it and tried the legacy version as well as the 2.x stable version, following the instructions on the download page.

This is the Apache2 Error I get when trying to restart apache2:

Fatal Error Unable to allocate shared memory segment of 67108864 bytes: mmap: Cannot allocate memory (12)