Phalcon versnio compability

Hey

I'm currently interested in Phalcon framework, I have a question about php version

my server is running 5.6.11 and Phalcon 2.0.6 is only comatable with HP 5.4.0 is there any problem if I use the higher version and what does NTS stand for ?



4.2k

From their documentation it looks like Phalcon is compatible with 5.4+ (Mac) or 5.3+ (Linux)

Mac (PHP 5.4+) : https://docs.phalconphp.com/en/latest/reference/install.html#mac-os-x PHP >= 5.4 development resources Linux (PHP 5.3+) : https://docs.phalconphp.com/en/latest/reference/install.html#linux-solaris PHP >= 5.3 development resources

I run it on 5.6.x (Ubuntu/CentOS) and 5.5.27 (CentOS) just fine.

Phalcon 2.0.x is compatible with PHP 5.4, 5.5, 5.6. No PHP 7 support yet, but phalcon developers are working on it.

NTS stands for Not Thread Safe

http://stackoverflow.com/questions/1623914/what-is-thread-safe-or-non-thread-safe-in-php