What is wrong with my phalcon installation?

I installed phalcon follow it's Compilation document , the command showed that I install and build succeed. But when I run config script <?php print_r(get_loaded_extensions()); ?> it reported error:

PHP Warning:  PHP Startup: Unable to load dynamic library '@@HOMEBREW_PREFIX@@/opt/php55-phalcon/phalcon.so' - dlopen(@@HOMEBREW_PREFIX@@/opt/php55-phalcon/phalcon.so, 9): image not found in Unknown on line 0
Warning: PHP Startup: Unable to load dynamic library '@@HOMEBREW_PREFIX@@/opt/php55-phalcon/phalcon.so' - dlopen(@@HOMEBREW_PREFIX@@/opt/php55-phalcon/phalcon.so, 9): image not found in Unknown on line 0

locate shows that there are two phalcon.so, the first was installed by phalcon's install sctipt, the second was installed by brew install php5x php5x-phalcon

/usr/local/Cellar/php55/5.5.27_2/lib/php/extensions/no-debug-non-zts-20121212/phalcon.so
/usr/local/Cellar/php55-phalcon/2.0.6/phalcon.so

I don't know where is the phalcon's config, maybe it found phalcon.so from the wrong place.

How to fix it?

edit:

I found the phalcon's config file and change the path of phalcon.so, and the error still there.

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/Cellar/php55-phalcon/2.1.6/phalcon.so' - dlopen(/usr/local/Cellar/php55-phalcon/2.1.6/phalcon.so, 9): image not found in Unknown on line 0
Warning: PHP Startup: Unable to load dynamic library '/usr/local/Cellar/php55-phalcon/2.1.6/phalcon.so' - dlopen(/usr/local/Cellar/php55-phalcon/2.1.6/phalcon.so, 9): image not found in Unknown on line 0

does your phpinfo() tell that the extention is loaded?

use this : brew install php5 php5-phalcon , remove the X