After install Phalcon: Access to undeclared static property: Phalcon\Di::$_default in

I use nginx/1.8.0 + PHP 5.6.9-0+deb8u1. Standard installation.

Assembly and installation Phalcon done through github.com. The current version Phalcon is 2.0.6.

When I connect extension Phalcon via /etc/php5/fpm/pool.d/site.conf как phpadminvalue[extension] = phalcon.so — I have an error.

When I connect extension Phalcon via /etc/php5/fpm/conf.d/30-phalcon.ini — OK.

How it works you can see on the video — http://www.youtube.com/watch?v=GdIuKleA12o&feature=youtu.be

P.S.: Sorry for my English.

Did you compile the extension by yourself or using the ppa?

edited Aug '15

I created the extension as:

$ git clone --depth=1 git://github.com/phalcon/cphalcon.git
$ cd cphalcon/build
$ sudo ./install

P.S.: Linux debian 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1+deb8u2 (2015-07-17) x86_64 GNU/Linux



4.3k

Same here with PHP 5.6.12 './configure' '--prefix=/opt/php-5.6.12' '--with-pdo-pgsql' '--with-zlib-dir' '--with-freetype-dir' '--enable-mbstring' '--with-libxml-dir=/usr' '--enable-soap' '--enable-calendar' '--with-curl' '--with-mcrypt' '--with-pgsql' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-zlib' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl' '--enable-mbregex' '--with-mhash' '--enable-zip' '--with-pcre-regex' '--with-mysql' '--with-pdo-mysql' '--with-mysqli' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--with-openssl' '--with-fpm-user=www-data' '--with-fpm-group=www-data' '--with-libdir=lib64' '--enable-ftp' '--with-kerberos' '--with-gettext' '--with-gd' '--with-jpeg-dir=/usr/lib/' '--enable-intl' '--enable-fpm'

NGINX php-pfm

Phalcon 2.0.6

Linux Ubuntu-1204-precise-64-minimal 3.8.0-42-generic #63~precise1-Ubuntu SMP Fri Jul 4 21:16:26 UTC 2014 x8664 x8664 x86_64 GNU/Linux

Keep getting random errors and bad gateway as well.