Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon App from Windows (WAMP) to Ububtu does not work

Hi, We have Phalcon based App working in Windows environment, we use UniServer WAMP. Now we are trying to move it to Ubuntu 14 server but it gives errors. It loads login page but not images & styling. After login it gives error saying requested url not found. How to find out what the reason for this & what should I look for? Thanks & regards... Uday



12.3k
Accepted
answer

make sure your paths are written correctly, since linux is case sensitive while windows isn't.



818

Hi Stefan, Thanks a lot, one problem was with mod_rewrite was not enabled. I did that and now sites starts loading. However as predicted by you correctly there is problem with file naming. My developer has referred model called "useractivity" where as file name is "UserActivity.php". So I get error, unfortunately there are 100s of models created & used. My developer is on leave and can't be reached for next 3-4 days. Is there any apache module or some other solution that it works like windows? Regards...

Uday

make sure your paths are written correctly, since linux is case sensitive while windows isn't.

if case sensitivity is the problem, then I'm not sure about another solution than renaming everything to match the filenames. I researched a bit, but I can't find any way to do this. Linux is written in a case sensitivity manner and enforces everything else to be written the same.

If you didn't do it yet, I recommed calling the model as "UserActivity" and give it a try, to make sure case sensitivity is the problem.