Upgrade phalcon on FreeBSD

Installed version 1.1.0 when trying to update gives the following

 # pkg_add -r phalcon
Fetching ftp://ftp.freebsd.org/pub/FreeBSD/ports/amd64/packages-9-stable/Latest/phalcon.tbz... Done.
pkg_add: package 'phalcon-1.2.1' or its older version already installed

Pls help, in linux I was a tree :(

edited Jul '14

Don't know if it will help you to solve the problem. But it looks like your system detects that you have already a more recent version. Lastest phalcon version is 1.2.3