Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

You can not delete or edit the CRUD problems findFirstBy

Hi I have problems using the CRUD generated by devtools it works keeping and paging but when Quere r edit or delete some data from tbala me the message "SPM_CONTACTO was not found" check the action of the driver that has the following meeting on fields but no but I find nothing wrong with them. By the way I'm working with Oracle

    if (!$this->request->isPost()) {


        $SPM_CONTACTO = SpmContacto::findFirstByCONT_CODIGO($CONT_CODIGO);
        if (!$SPM_CONTACTO) {
            $this->flash->error("SPM_CONTACTO was not found");

            return $this->dispatcher->forward(array(
                "controller" => "SPM_CONTACTO",
                "action" => "index"
            ));
        }

        $this->view->CONT_CODIGO = $SPM_CONTACTO->CONT_CODIGO;

        $this->tag->setDefault("CONT_CODIGO", $SPM_CONTACTO->CONT_CODIGO);
        $this->tag->setDefault("CONT_CEDULA", $SPM_CONTACTO->CONT_CEDULA);
        $this->tag->setDefault("CONT_RUCIDE", $SPM_CONTACTO->CONT_RUCIDE);
        $this->tag->setDefault("CONT_NOMBRE", $SPM_CONTACTO->CONT_NOMBRE);
        $this->tag->setDefault("CON_ESTADO", $SPM_CONTACTO->CON_ESTADO);
        $this->tag->setDefault("CONT_TELEFO", $SPM_CONTACTO->CONT_TELEFO);
        $this->tag->setDefault("CONT_DIRECC", $SPM_CONTACTO->CONT_DIRECC);
        $this->tag->setDefault("CONT_AREA", $SPM_CONTACTO->CONT_AREA);
        $this->tag->setDefault("CONT_CARGO", $SPM_CONTACTO->CONT_CARGO);
        $this->tag->setDefault("CONT_TIPOXX", $SPM_CONTACTO->CONT_TIPOXX);

    }
edited Sep '15

Most people here speak English. I suggest you change your subject line to English to get more replies.



34.2k

For that reason I put it in both languages. but since one English public



34.2k

ready could help me with this if I could not explain well



34.2k
Accepted
answer

In the current version already they got this problem solving

git clone  git://github.com/phalcon/cphalcon.git
cd cphalcon/ext
git checkout 2.0.x
sudo ./install(edited)