Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

gcc compilation error missing gccarch.c

This:

# apt-get install php5-dev php5-mysql libpcre3-dev autoconf curl wget build-essential
# git clone --depth=1 git://github.com/phalcon/cphalcon.git /tmp/phalcon
# /tmp/phalcon/build/install

Outputs this:

Cloning into '/tmp/phalcon'...
remote: Counting objects: 2245, done.                                                                                                                              
remote: Compressing objects: 100% (1761/1761), done.                                                                                                               
remote: Total 2245 (delta 787), reused 997 (delta 312), pack-reused 0                                                                                              
Receiving objects: 100% (2245/2245), 4.01 MiB | 3.02 MiB/s, done.
Resolving deltas: 100% (787/787), done.
Checking connectivity... done.
gcc: error: gccarch.c: No such file or directory
gcc: fatal error: no input files
compilation terminated.
/tmp/phalcon/build/install: line 55: cd: 32bits: No such file or directory
Cannot find config.m4. 
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

Does anyone know why?

I'm trying to compile phalcon on an updated Ubuntu 14.04 installation with NGINX 1.8.0, PHP-FPM 5.6.9 and MariaDB 10.0. The Ubuntu phalcon repository does not work because of the PHP version.



64.4k
Accepted
answer
$ cd cphalcon/build/64bits
$ make clean
$ phpize --clean
$ _YOUR_PHP_INSTALITION_PATH_FOR_PHP_5_6_9/bin/phpize
$ ./configure --with-php-config=_YOUR_PHP_INSTALITION_PATH_FOR_PHP_5_6_9/bin/php-config
$ make && sudo make install