Can't Install "Depends: phpapi-20090626"

Hello,

when I try to install, I got this message :

The following packages have unmet dependencies: php5-phalcon : Depends: phpapi-20090626 E: Unable to correct problems, you have held broken packages.

I am using vagrant + ubuntu server 12 LTS + php 5.6

Please give me know what is the problem and how to solve this.

Thank you.



11.5k
edited Oct '15

You probably need to install libapache2-mod-php5 or similar. If you are not using apache, then maybe install php5-cgi, and your dependencies should be met. See https://packages.debian.org/squeeze/phpapi-20090626. In other words it sounds like you have installed php but have not installed a SAPI - server has no API through which to serve PHP, therefore Phalcon can not be served.



36.3k

Hi

Try to the command below

cd ~/cphalcon/ext
phpize && ./configuration && make && make install


64.1k

since its 5.6 its not installed from source, so I think

$ cd cphalcon/build/64bits
$ make clean
$ phpize --clean
$ _YOUR_PHP_INSTALITION_PATH_FOR_PHP_5_6/bin/phpize
$ ./configure --with-php-config=_YOUR_PHP_INSTALITION_PATH_FOR_PHP_5_6/bin/php-config
$ make && sudo make install

You can also try my PPA instead: https://launchpad.net/~sidroberts/+archive/ubuntu/phalcon as it's designed to work with PHP 5.6.



1.5k

@Al I have install php5-cgi, but it still failed